[F] MIDI Forwarding to MIDI Out 2 is not working on Mac

Report any bug you find here!
Topics ar marked as: [R]=Rejected, [A]=Approved, [WIP]=Work in Progress, [F]=Fixed
Post Reply
Simon
Posts: 873
Joined: 09 Jan 2022, 22:08

[F] MIDI Forwarding to MIDI Out 2 is not working on Mac

Post by Simon »

Short description of the issue: USB Midi

Setup (devices connected to the Midronome and how): macOS Sonoma on M1 mac, Midronome plugged in using USB

Steps to Reproduce: Simply try to use the USB forwarding interfaces MIDI Out 2, it does not forward, instead the USB-MIDI "Midi Out 2" acts like "Commands"

Expected Behavior: MIDI Out 2 messages are sent on the physical MIDI output #2

Actual Behavior: MIDI Out 2 messages are sent internally to MIDI Commands

Midronome firmware version: v2.0


This is a macOS bug, this works fine on Windows. It seems macOS does not like when a device has a different amount of input and outputs USB-MIDI interfaces (Firmware v2.0 has 3 INs and 2 OUTs).
Simon
Posts: 873
Joined: 09 Jan 2022, 22:08

Re: MIDI Forwarding to MIDI Out 2 is not working on Mac

Post by Simon »

This will be solved in Firmware v3.0 and up by adding extra input interfaces, ending with this configuration:

3 MIDI Outputs: (same as current)
  • Commands
  • MIDI Out 1
  • MIDI Out 2
3 MIDI Inputs:
  • Clock
  • Module Itf 1
  • Module Itf 2
Clock is the usual input where the clock is sent, as well as Start/Stop messages.
The two Module Itf X inputs will be used as forwarding interfaces when sending MIDI messages to a MIDI IN module for example, these messages will be forwarded there.

Let me know if you have any other ideas / suggestions :)

Cheers
Simon
Post Reply