[F] soling tracks ableton loses sync

Report any bug you find here!
Topics ar marked as: [R]=Rejected, [A]=Approved, [WIP]=Work in Progress, [F]=Fixed
Post Reply
9000knobs
Posts: 1
Joined: 07 Nov 2023, 18:25

[F] soling tracks ableton loses sync

Post by 9000knobs »

(please follow this template when submitting a new bug report - feel free to add more information)


Short description of the issue:
When using the vst plugin in ableton and having the clock running, when user presses SOLO on any audio or midi track, the daw loses connection with the sync. because the midronome track is disabled.

Setup (devices connected to the Midronome and how):
Midronome connected with usb cable to desktop PC
Midi cable connected to Input AKAI force , clock signal goes to DFAM
Steps to Reproduce:
setup plugin as normal using audio output soundcard to input on midronome
Expected Behavior:
i expect the clock to keep syncing off course when soloing instruments in ableton, but it might be just expected behaviour and not a bug.
Actual Behavior:
the clock loses sync when solo is on and resyncs when solo is turned off again
ErrorLog (from the ErrorLogExtractor - https://midronome.com/support ):

Has the Midronome firmware been recently upgraded, from which version to which version?
firmware 2.0
Simon
Posts: 876
Joined: 09 Jan 2022, 22:08

Re: soling tracks ableton loses sync

Post by Simon »

Thanks for reporting :)
Though I am going to reject this as it is an Ableton issue not a Midronome Plugin issue.

The Midronome plugin is on a track, so yes when you solo another track all other tracks are muted, including the Midronome plugin track: so the sync stops, that makes sense.

What you are looking for is a feature called "Solo safe" or "Solo exempt", which unfortunately does not exist in Ableton. But there are a few workarounds, see here: https://forum.ableton.com/viewtopic.php?t=202627

Cheers
Simon
Simon
Posts: 876
Joined: 09 Jan 2022, 22:08

Re: [Workaround] soling tracks ableton loses sync

Post by Simon »

Well you can thank Nektarios who just posted a solution in the Midronome FB Group:
nektarios wrote:For users of (un)Ableton Live which still doesn't have a solo safe/defeat function and every time you solo something, your Midronome VST track gets muted (along with the clocks going to your hardware).
Using the "External audio effect" utility, works but its a device that induces a whooping 30.4ms of latency at 512 buffer size...far from ideal.
But for those who don't know, there is a free max4live device called "Solo Safe" which you place right after your Midronome VST and it defeats soloing that track and is a 0 samples latency device.
Just tried, it works and its free.
https://maxforlive.com/library/device/3447/solo-safe
Attachments
solo-safe-Ableton.jpg
solo-safe-Ableton.jpg (6.22 KiB) Viewed 4445 times
nektarios
Posts: 3
Joined: 01 Dec 2023, 23:38

Re: [Workaround] soling tracks ableton loses sync

Post by nektarios »

Nice one Simon.
It works and it’s free. 8-)
Simon
Posts: 876
Joined: 09 Jan 2022, 22:08

Re: [F] soling tracks ableton loses sync

Post by Simon »

This is now fixed in FW 3.0 with U-SYNC.
MPrinsen
Posts: 74
Joined: 01 May 2023, 13:42

Re: [F] soling tracks ableton loses sync

Post by MPrinsen »

This is also fixed if you use my prefered method: send the audio signal to Midronome by using the External Audio Effect device instead of the regular track output.
Post Reply