[F] ANLG clock off by 1 MIDI tick when using USB+Reset Mode

Reported bugs for the Midronome hardware or firmware.
Topics ar marked as: [R]=Rejected, [A]=Approved, [WIP]=Work in Progress, [F]=Fixed
Forum rules
  • Use the search function to see if your bug has already been reported
  • Only post in a topic if it is directly related to the reported bug or feature. If not or if you're not sure, please use the Discussions & debates forum.
Thank you so much for reporting bugs <3 - it helps A LOT :)
Post Reply
Simon
Posts: 780
Joined: 09 Jan 2022, 22:08

[F] ANLG clock off by 1 MIDI tick when using USB+Reset Mode

Post by Simon »

STATUS: Fixed in Firmware v1.1 - download it here: viewtopic.php?t=238


Short description of the issue: both clocks coming out of the ANLG plug are delayed by 1 tick when having a specific setup (see below)

Setup: Midronome connected to a computer BUT without any software asking for MIDI (tested on Mac only)
Reset mode enabled, and ANLG clock set to PLA (An.L=PLA)

Steps to Reproduce: Press the PLAY button

Expected Behavior: the ANLG clocks should be on the same tick as the first MIDI tick

Actual Behavior: the ANLG clocks are delayed by one tick, and sometimes there is an extra pulse on the ANLG on the first tick
Simon
Posts: 780
Joined: 09 Jan 2022, 22:08

Re: [WIP] ANLG clock off by 1 MIDI tick when using USB+Reset Mode

Post by Simon »

This was a tricky one. It is caused by the MIDI Start message sent over USB: even though the OS has configured the USB device, it will not ask for any MIDI packets on the USB bus until a software asking for MIDI Data is open. So the Midronome was waiting for the USB queue to be cleared, which never happened and would only timeout after one tick, which was too late already to prepare for the next tick, hence the 1 tick delay.

The code has been improved so that there is no timing out now, it just handles this particular case differently ;)

The fix will be released with the next firmware version.
Simon
Posts: 780
Joined: 09 Jan 2022, 22:08

Re: [WIP] ANLG clock off by 1 MIDI tick when using USB+Reset Mode

Post by Simon »

Fixed in Firmware v1.1 - download it here: viewtopic.php?t=238
Post Reply